Адаптация шаблонов Dle 10.4 до DLE 10.5

Раздел: DataLife Engine » Полезные статьи для DLE
Адаптация шаблонов Dle 10.4 до DLE 10.5
Представляем на http://www.dle9.com/ мануал: адаптация шаблонов DLE 10.4 до версии DLE 10.5 - эти изменения в шаблонах надо выполнить при переходе на новую версию Dle 10.5 движка DataLife Engine 10.5.

Скачать Dle 10.5 движок DataLife Engine v.10.5 (новые лицензионные версии Win1251 - UTF8), чтобы опробовать все новые возможности, модули, хаки, шаблоны DLE и навороты добавленные разработчиками о которых мы писали в новостном обзоре DLE 10.5 Пресс релиз DataLife Engine v.10.5
Важные изменения между версиями 10.4 и 10.5 в шаблонах которые необходимо выполнить для использования версии движка Dle 10.5 DataLife Engine 10.5

Внимание! Изменения в во всех шаблонах Dle следует выполнять только в такой последовательности.
Пример: если версия Ваша движка была ниже 10.4 и перешли на версию выше, то внесение изменений в шаблоны делается в порядке очередности от версии к версии, в зависимости от той версии с которой вы обновлялись. Например вы проводили обновление скрипта DLE с версии 10.1 до версии 10.4, то в данном случае вам нужно поочередно вносить изменения, сначала те, которые были между версиями dle 10.1 и dle 10.2, потом изменения которые были между версиями 10.2 и dle 10.3, потом изменения между версиями 10.3 и 10.4 и т.д.


Адаптация шаблонов Dle 10.4 до DLE 10.5 или Изменения в шаблонах DLE между версиями 10.4 и 10.5
Все этапы адаптации вы сможете посмотреть у нас начиная с 8.5 до 10.5:
Изменения между версиями 10.3 и 10.4 ,
Изменения между версиями 10.2 и 10.3 ,
Изменения между версиями 10.1 и 10.2 ,
Изменения между версиями 10.1 и 10.0 ,
Изменения между версиями 10.0 и 9.8,
Изменения между версиями 9.8 и 9.7,
Изменения между версиями 9.7 и 9.6
Изменения между версиями 9.6 и 9.5 и т.д. остальные смотрите в категории Все для DLE

Информация об изменениях в шаблонах версии 10.3 и 10.5 было взято с офиц. портала dle-news

Узнать и скачать 10.4 (лицензионные версии Win1251 - UTF8), чтобы опробовать все возможности добавленные разработчиками о которых мы писали в новостном обзоре DataLife Engine v.10.4 DLE 10.4 Press Release.

Полезная статья на сайте DLE http://www.dle9.com .
  • 100
Рубрика: Все для DLE » Полезные статьи
Ранее » Накрутка лайков и подписчиков соц.сетей (бесплатно)« Далее Яндекс Минусинск
Добавление комментарияОставить комментарий
  • № :11
  • 18 сентября 2015 16:08
Цитата: Hipi
Еще один вопрос скачал шаблон интернет магазина не могу понять как с ним работать. а точнее не могу разместить на нем ни код товара ни наименование ни слайд шоу. Вот этот шаблон DLEshopBlue может кто нибудь на нем работал подскажет?

Шаблон - это оформление сайта его дизайн, а то что вам нужно это модуль интернет магазина который и выводит товар в шаблоне Модуль DLE 10.0 SHOP 1.1 интернет магазин

Слайдер придется прикрутить отдельно и настроить.

Помогать вам делать сайт вряд ли кто будет (все таки это время и силы) и все это ваш сайт, если только фрилансера наймете в интернет, есть сайт там можно найти человека.
  • № :10
  • 18 сентября 2015 13:43
Еще один вопрос скачал шаблон интернет магазина не могу понять как с ним работать. а точнее не могу разместить на нем ни код товара ни наименование ни слайд шоу. Вот этот шаблон DLEshopBlue может кто нибудь на нем работал подскажет?
  • № :9
  • 18 сентября 2015 09:02
Цитата: hipi
здравствуйте СКАЧАЛ ШАБЛОН ДЛЯ ДЛЕ 10,5 УСТАНОВИЛ У МЕНЯ ВМЕСТО БУКВ ЗНАКИ ВОПРОСА В РОМБЕ. КАК ЭТО ИСПРАВИТЬ?

ответ здесь вероятней всего у вашего движка одна кодировка а вы использовали шаблон с другой кодировкой отсюда проблема.

ПС. Не пишите прописными буквами и так видно!
  • № :8
  • 18 сентября 2015 08:09
здравствуйте СКАЧАЛ ШАБЛОН ДЛЯ ДЛЕ 10,5 УСТАНОВИЛ У МЕНЯ ВМЕСТО БУКВ ЗНАКИ ВОПРОСА В РОМБЕ. КАК ЭТО ИСПРАВИТЬ?
  • № :7
  • 26 июля 2015 13:37
Цитата: tihjawi
Скажите, пожалуйста, есть ли смысл переходить с PHP 5.3 на PHP 5.5, если учесть, что разные сторонние модули у меня не установлено. Может быть стабильность, безопасность, либо скорость работы увеличится?

Да стоит. Скорость не увеличится, даже скорее наоборот, может незначительно упасть. А вот безопасность и стабильность будут на много безопасней, т.к. линейка PHP 5.3 уже не поддерживается разработчиками PHP, а в нем периодически также повышается и стабильность и безопасность стандартных функций PHP.
  • № :6
  • 26 июля 2015 13:34
Скажите, пожалуйста, есть ли смысл переходить с PHP 5.3 на PHP 5.5, если учесть, что разные сторонние модули у меня не установлено. Может быть стабильность, безопасность, либо скорость работы увеличится?
  • № :5
  • 16 июля 2015 11:09
Спасибо, что ответили! Но проблема заключалась в функции "Включить поддержку авторизации на сайте", я ее включил и все нормально стало. Просто сто лет сидел на 10.0, а в 10.5 появились новые функции, не привычно как-то.
  • № :4
  • 16 июля 2015 10:41
Цитата: alex205
Заново переустановил теперь показывает 10.5. Но теперь я не могу авторизироваться на сайте, в панель нормально захожу, а на самом сайте не могу войти, страница просто обновляется. Может вы знаете как исправить?

проблема связана с тем, что в вашем шаблоне используются старый запрос скриптов JS входа .
Решения два
1. вернуть старые файлы JS скриптов в движке engine/classes/js/
jquery.js и jqueryui.js просто заменить их от версии ниже dle 10.3
2. или взять от дефаулт шаблона панель регистрации или использовать от туда код, но для этого надо зание HTML вёрстки
  • № :3
  • 16 июля 2015 09:50
Заново переустановил теперь показывает 10.5. Но теперь я не могу авторизироваться на сайте, в панель нормально захожу, а на самом сайте не могу войти, страница просто обновляется. Может вы знаете как исправить?
  • № :2
  • 16 июля 2015 03:53
Цитата: alex205
Обновил с 10.0 до 10.5 поочередно. Панель обновилась. Но в ней показывает, что стоит версия 10.0. Как это исправить?

вы обновили шаблон. теперь нужно обновить движок, скачать dle 10.5 и сделать по инструкции что в статье в самом конце
  • № :1
  • 15 июля 2015 19:37
Обновил с 10.0 до 10.5 поочередно. Панель обновилась. Но в ней показывает, что стоит версия 10.0. Как это исправить?