Модуль Оплата VIP подписки v.1.0

Категория: Модули DLE » Модуль для DLE 11.3, 11.2, 11.1, 11.0, 10.6, 10.5, 10.4, 10.3, 10.2, 10.1, 10.0, 9.8, 9.7, 9.6, 9.5, 9.4, 9.3, 9.2, 9.0
Модуль Оплата VIP подписки v.1.0
Полезный модуль для DLE 10.2 Оплата VIP подписки v.1.0 позволяет пользователям вашего сайта переходить в определённую группу VIP на время, которое нужно оплатить из своего кармана. Этот модуль для DLE распространен на сайтах, где только избранным пользователям доступны самые интересные разделы, файлы и информация.
Модуль Оплата VIP подписки v.1.0

Модуль для DLE 10.2 Оплата VIP подписки v.1.0 прост в установке и настройке.
www.dle9.com
Установка модуля

1. Залейте файлы из папки upload себе на сервер в аналогичные разделы,
Очень важно поменять название папки templates/Default на название вашего шаблона
2. Для установки админпанели пройдите по адресу сайт.ру/admin.php?mod=buyvip
3. Для установки пользовательской части откройте файл main.tpl вашего шаблона, найдите:
{content}


и замените на:

[aviable=subscribe]{include file="engine/modules/buyvip.php"}[/aviable]
[not-aviable=subscribe]{content}[/not-aviable]


Теперь модуль доступен по адресу
сайт.ру/?do=subscribe


Важно! В настройках VIP группы должно быть разрешено "временное размещение в группе".

Datalife engine: 10.2
Автор: mr_Evgen

Требуется установка модуля Баланс пользователя v.0.3

Как сделать помесячную оплту, а не подневную. То есть как сделать чтобы можно было выбрать только 1,2,3 и т.д месяца, а не дней.

engine/modules/buyvip.php
найти
$days*24*60*60

заменить на
$days*24*60*60*30

теперь пользователь оплачивает не дни, а месяца.
в админ.панели установить цену не 1 дня, а 1 месяца
Скачать из раздела модули для dle, как модуль Оплата VIP подписки v.1.0
Для работы модуля необходим модуль Баланс пользователя v.0.3 и выше. Скачать
Модуль Оплата VIP подписки v.1.0 для DLE позволяет пользователям вашего сайта переходить в определённую группу VIP на время, которое нужно оплатить вы найдете всё лучшее у нас форумы, хаки, модули, шаблоны.
  • 80
Рубрика: DLE модули
Ранее » Форма обратной связи для DLE Fast-Feedback« Далее Модуль для DLE Мониторинг обменников
Добавление комментарияОставить комментарий
  • № :19
  • 7 июня 2017 07:14
Цитата: Gabiz
Цитата: dle9.com
суть ошибки не может найти файл или адрес неверен

иногда для защиты админки изменяют адрес или название файла, может в это дело

сайт.ру/admin.php

адрес не изменял, ни каких правок в файлах не делал

проблема явно с движком или настройкой безопасности

спросите у хостинга (может проблема у вас тоже в PHP
Внимание! У вас нет прав для просмотра скрытого текста.
)
  • № :18
  • 6 июня 2017 22:26
Цитата: dle9.com
суть ошибки не может найти файл или адрес неверен

иногда для защиты админки изменяют адрес или название файла, может в это дело

сайт.ру/admin.php

адрес не изменял, ни каких правок в файлах не делал
  • № :17
  • 6 июня 2017 18:03
Цитата: Gabiz

файл .htaccess присутствует

суть ошибки не может найти файл или адрес неверен

иногда для защиты админки изменяют адрес или название файла, может в это дело

 сайт.ру/admin.php
  • № :16
  • 6 июня 2017 17:02
Цитата: dle9.com
Цитата: Gabiz
Цитата: dle9.com
а файлы проверили на месте, правильно их залили в папки ??

да, конечно все провели!! Сделал все как по инструкции

осталось проверить есть ли в папке engine/modules/
файл
.htaccess может в результате обновления он не был добавлен и защищает от включения посторонних скриптов

файл .htaccess присутствует
  • № :15
  • 6 июня 2017 16:08
Цитата: Gabiz
Цитата: dle9.com
а файлы проверили на месте, правильно их залили в папки ??

да, конечно все провели!! Сделал все как по инструкции

осталось проверить есть ли в папке engine/modules/
файл
.htaccess может в результате обновления он не был добавлен и защищает от включения посторонних скриптов
  • № :14
  • 6 июня 2017 13:03
Цитата: dle9.com
а файлы проверили на месте, правильно их залили в папки ??

да, конечно все провели!! Сделал все как по инструкции
  • № :13
  • 5 июня 2017 21:13
Цитата: Gabiz
11.3 стоит, есть тестовый сайт, с этой же версией движка на том же хостинге и тем же шаблоном, но на тестовом все ок, а на основном такая ошибка

а файлы проверили на месте, правильно их залили в папки ??
  • № :12
  • 5 июня 2017 15:54
11.3 стоит, есть тестовый сайт, с этой же версией движка на том же хостинге и тем же шаблоном, но на тестовом все ок, а на основном такая ошибка
  • № :11
  • 5 июня 2017 12:48
Цитата: Gabiz
Привет, помогите! При переходе по сайт.ру/admin.php?mod=buyvip
пишет, что сайт недоступен (ошибку в браузере выдает), попробуйте зайти позже! Что это такое и как с этим Бороться?

Привет,проверьте в другом браузер, возможно защита на хостинге стоит, проблема только у вас такая.. версию движка надо написать, чтобы было понятно
  • № :10
  • 5 июня 2017 11:31
Привет, помогите! При переходе по сайт.ру/admin.php?mod=buyvip
пишет, что сайт недоступен (ошибку в браузере выдает), попробуйте зайти позже! Что это такое и как с этим Бороться?
  • № :9
  • 30 мая 2017 09:31
На дле 11.0 работает??
  • № :8
  • 10 декабря 2015 18:44
Цитата: vasiliu
он работает с http://www.dle9.com/moduli/3785-modul-balans-polzovatelya-04.html я так понял

не проверял но те кто пользовался писали что можно
  • № :7
  • 10 декабря 2015 18:02
он работает с http://www.dle9.com/moduli/3785-modul-balans-polzovatelya-04.html я так понял
  • № :6
  • 17 февраля 2015 11:20
Цитата: ProgrammHacK
1.Версия DLE 10.4
2.Fatal error: Call to undefined function save_setting() in /home/p272111/www/galactic-battle ru/engine/inc/buyvip.php on line 34
Прошу помочь в чём дело.

1 вопрос ошибка сразу появилась или со временем, если со временем сделайте ремонт Базы Данных в админке дле, почистите кеш и проверяйте
2. Есть вероятность, что модуль нужно адаптировать ставьте Денвер и устанавливайте 10.2 и проверяйте, если будет работать ищем адаптированную версию почему это происходит читаем здесь
  • № :5
  • 17 февраля 2015 10:35
1.Версия DLE 10.4
2.Fatal error: Call to undefined function save_setting() in /home/p272111/www/galactic-battle ru/engine/inc/buyvip.php on line 34
Прошу помочь в чём дело.
  • № :4
  • 26 января 2015 04:13
Не могу настроить webmoney:
Метод MD5 не поддерживается. Используйте SHA256 или SIGN.(150)
  • № :3
  • 5 сентября 2014 21:34
А у меня такая проблема при установке админки
Fatal error: Call to undefined function save_setting() in Z:\home\localhost\www\sayt.net\engine\inc\buyvip.php on line 34
  • № :2
  • 2 августа 2014 19:00
Разобрался! В файле engine/inc/buyvip.php щаменить строку 61 на
$ADM_theme->select("Включить модуль:", "Разрешить пользователям покупать подписку.", makeDropDown(array ("1" => "Вкл.", "0" => "Выкл." ), "save_con[status]", $buyvip_config['status']) );


Версия DLE 9.6
  • № :1
  • 2 августа 2014 17:38
Помогите!!! Версия движка 9.6 при переходе admin.php?mod=buyvip
такая ошибка:
Fatal error: Call to undefined function makeCheckBox() in /.../.../.../engine/inc/buyvip.php on line 61