Онлайн 2.5.0 модуль для DLE 10.х-9.5

Категория: Модули DLE » Модуль для DLE 11.2, 11.1, 11.0, 10.6, 10.5, 10.4, 10.3, 10.2, 10.1, 10.0, 9.8, 9.7, 9.6, 9.5, 9.4, 9.3, 9.2, 9.0
Онлайн 2.5.0 модуль для DLE 10.х-9.5
Сегодня на http://www.dle9.com/ все для сайта dle советуем Онлайн 2.5.0 модуль для DLE 10.х-9.5 , так как многие переходят на новую версию скрипта DataLife Engine v10.0, то для корректной работы необходимо произвести адаптацию, что и было сделано автором в online модуле. Благо он обладает многими наворотами, основное предназначение выводить список пользователей, роботов, гостей, что находятся у вас на интернет-портале.

Онлайн модуль количество пользователей является один из популярных скриптов в движке дле, ведь он наглядно показывает сколько гостей на данный момент у вас, а чтобы увеличить потенциал веб-сайта ещё больше, советуем обратить внимание на QuickChat, позволяющий подключить онлайн оператора, который сможет помочь, ответить на любые вопросы вашей аудитории в считанные минуты.

Добротный Онлайн 2.5.0 модуль для DLE 10.х-9.5, позволит вам вывести список ваших пользователей, гостей, роботов в всплывающем окне, при этом показать страну и город, если у него реальный IP, при условии, что вы установили файл геолокации. Есть возможность видеть местоположения посетителя, определять операционную систему, браузер и даже составлять список пришедших зарегистрированных пользователей на веб-ресурс. О других возможностях читаем под спойлером.





Для тех у кого ошибка
Fatal error: Call to a member function GetOnUser() on a non-object in online.php on line 16

1. Добавить файл в папку \engine\data\GeoLiteCity.dat ниже можно скачать, если нет желания устанавливать такой большой файл и хотите отказаться от вывода флагов, страны, ip и т.д. то делаем следующее:

2. В панели движка ДЛЕ выбираем Все разделы панели (Список всех разделов) спускаемся в самый низ и выбираем Сторонние модули - Блок онлайн.
Далее выбираем вкладку Настройки хинта (Настройки всплывающего окна) и ставим во всех вкладках Не Показывать, потом Сохраняем изменения. Всё ошибки больше быть не должно!

3. Если выходит ошибка значит настройки не сохранились на вашем хостинге! Делаем следующее; ставим права 777 на файл data/engine/online_config.php и повторяем пункт 2, не помогает открываем файл data/engine/online_config.php в любом блокноте и правим в этих местах ставим NO, т.е. отключаем функцию геолокации, сохраняем и добавляем файл на сервер.
'show_location' => "no",

'show_country_flag' => "no",

'show_country' => "no",

'show_city' => "no",

'show_last_visit' => "no",

'show_user_group' => "no",

'show_ip' => "no",

'show_proxy' => "no",

'show_user_OS' => "no",

'show_browser_icon' => "no",

'show_avatar_def' => "no",

В этом случаи должно быть 100% получиться!

Название: Онлайн / Online
Автор: Igor100
Доработал модуль: SX2
Адаптировал до DLE 10.х - 9.5: Qnut and Panacea
Версия модуля: 2.5.0

Скачать Online CP-1251 UTF-8: , Внимание если вам необходимо видеть геолокацию пользователя (страну по IP), то дополнительный файл должен быть распаковать в папку \engine\data\GeoLiteCity.dat из данного архива blok-onlayn-GeoLiteCity.rar [16.98 Mb]
  • 40
Рубрика: DLE модули » Бесплатные
Ранее » Модуль Награды / Awards 4.5 для DLE 10.0 - 9.7« Далее Модуль DLE 10.0-9x MySiteBackup
Добавление комментарияОставить комментарий
  • № :87
  • 3 сентября 2016 14:06
Цитата: maxno
До этого модуль работал все нормально, вчера в шаболоне (shortstory.tpl) кой какие div class добавлял,потом само по себе ошибка выдал модуль онлайн

от div class такой ошибки не может быть, сбой произошел ...
Если все работало чистить кеш, сделать ремонт БД ...
  • № :86
  • 3 сентября 2016 12:44
До этого модуль работал все нормально, вчера в шаболоне (shortstory.tpl) кой какие div class добавлял,потом само по себе ошибка выдал модуль онлайн
  • № :85
  • 3 сентября 2016 12:39
Цитата: dle9.com
Цитата: maxno
Как Вы думайте что за ошибка?

Fatal error: Call to undefined function geoip_record_by_addr() in /home/name/domains/site.ru/public_html/engine/modules/online/online.class.php on line 211

строчка:
Внимание! У вас нет прав для просмотра скрытого текста.

решение есть в комментариях ниже


Я бы не хотел отключать эти функции
'show_country_flag' => "yes",

'show_country' => "yes",

'show_city' => "yes",


если Вы это имеете виду...
по другому не как нелзя решать?
  • № :84
  • 3 сентября 2016 12:30
Цитата: maxno
Как Вы думайте что за ошибка?

Fatal error: Call to undefined function geoip_record_by_addr() in /home/name/domains/site.ru/public_html/engine/modules/online/online.class.php on line 211

строчка:
Внимание! У вас нет прав для просмотра скрытого текста.

решение есть в комментариях ниже
  • № :83
  • 3 сентября 2016 12:18
Как Вы думайте что за ошибка?

Fatal error: Call to undefined function geoip_record_by_addr() in /home/name/domains/site.ru/public_html/engine/modules/online/online.class.php on line 211

строчка:
Внимание! У вас нет прав для просмотра скрытого текста.
  • № :82
  • 19 августа 2016 13:58
Цитата: korel
Цитата: dle9.com
если вы возьмете файлы из папки templates и перенести в эту версию модуля, то все будет отображаться нормально, так как там находятся настройки отображения модуля.

Ты скажи какие фалы перенести?

Опять это "ты".... вниз спуститесь, комментарий №61, файл в котором производятся изменения вам и нужен. Это же логично.
  • № :81
  • 19 августа 2016 10:37
Цитата: dle9.com
если вы возьмете файлы из папки templates и перенести в эту версию модуля, то все будет отображаться нормально, так как там находятся настройки отображения модуля.

Ты скажи какие фалы перенести?
  • № :80
  • 16 августа 2016 14:20
Цитата: korel
я ставил мод с другого сайта в этот блок и хинт показывал норм, значит проблема в самом модуле, подправь модуль!

я модули не адаптирую, шаблонов хватает, но могу помочь,

если вы возьмете файлы из папки templates и перенести в эту версию модуля, то все будет отображаться нормально, так как там находятся настройки отображения модуля.
  • № :79
  • 16 августа 2016 13:27
я ставил мод с другого сайта в этот блок и хинт показывал норм, значит проблема в самом модуле, подправь модуль!
  • № :78
  • 15 августа 2016 19:58
Цитата: korel
Цитата: dle9.com
место вывода модуля поменяйте, он у вас то ли в таблице шаблона, то ли ещё как-то закрыт спустите ниже код вывода блока модуля...

напиши пожалуйста, что прописывать и в каком файле?

ну это вам видней, мне ваш шаблоне не известен, проще будет объяснить так, добавьте код для вывода модуля
5. В нужное место в main.tpl вставляем {include file="engine/modules/online/online.php"}


в шаблон от движка и увидите, что модуль нормально отображается. Так проверите, что модуль полностью нормально работает.
В вашем шаблоне куда вы добавили код стили закрывают весь блок, установите код выше в другое место и блок будет отображаться нормально
  • № :77
  • 15 августа 2016 17:01
Цитата: dle9.com
место вывода модуля поменяйте, он у вас то ли в таблице шаблона, то ли ещё как-то закрыт спустите ниже код вывода блока модуля...

напиши пожалуйста, что прописывать и в каком файле?
  • № :76
  • 15 августа 2016 16:53
Цитата: korel
поставил и прописал, хинт появился но он из блока не вылазиет, вот -
Внимание! У вас нет прав для просмотра скрытого текста.

место вывода модуля поменяйте, он у вас то ли в таблице шаблона, то ли ещё как-то закрыт спустите ниже код вывода блока модуля...
  • № :75
  • 15 августа 2016 16:18
поставил и прописал, хинт появился но он из блока не вылазиет, вот -
Внимание! У вас нет прав для просмотра скрытого текста.
  • № :74
  • 15 августа 2016 15:26
где то я читал, его надо положить в \templates\МОЙ ШАБЛОН\js\ и прописать, но что и как я в этом не очень, посмотри, может у тебя есть какие то идеи по этому поводу!
  • № :73
  • 15 августа 2016 14:43
Цитата: dle9.com
там могла быть адаптированная версия, а заменить js скрпты не пробовали от той версии. ?

там файл лежит в \upload\templates\МОЙ ШАБЛОН\js\ и вот здесь, а в данном модуле он находиться \upload\engine\modules\online, может в этом вся причина, этого модуля?
поставил от того, он тоже не пашет!
  • № :72
  • 15 августа 2016 05:39
Цитата: korel
Цитата: dle9.com
остается вариант с новыми JS- скриптами которые были добавлены разработчиками дле, чтобы это проверить попробуйте заменить

Вариант использовать старые js-скрипты от старой версии дле 10 файлы engine/classes/js/jquery.js и engine/classes/js/jqueryui.js заменить вместо старыми от версии 10.0 и проверить, чаще бывает в них проблема

нет проблема не в этом, а именно в данной сборки что то не так с js-скрипты так как я ставил с другого сайта подобный модуль, там у меня всё нормально было, но там не было вин 8,8.1 и 10 я добавлял но выходили ошибки, пришлось снести. В данной сборке с js-скриптами что не то!


там могла быть адаптированная версия, а заменить js скрпты не пробовали от той версии. ?
  • № :71
  • 15 августа 2016 03:41
yt
Цитата: dle9.com
остается вариант с новыми JS- скриптами которые были добавлены разработчиками дле, чтобы это проверить попробуйте заменить

Вариант использовать старые js-скрипты от старой версии дле 10 файлы engine/classes/js/jquery.js и engine/classes/js/jqueryui.js заменить вместо старыми от версии 10.0 и проверить, чаще бывает в них проблема

нет проблема не в этом, а именно в данной сборки что то не так с js-скрипты так как я ставил с другого сайта подобный модуль, там у меня всё нормально было, но там не было вин 8,8.1 и 10 я добавлял но выходили ошибки, пришлось снести. В данной сборке с js-скриптами что не то!
  • № :70
  • 14 августа 2016 18:04
Цитата: korel
я вообще то из всех папок по папкам раскидывал и переименовывать в моё случае нет смысла!

остается вариант с новыми JS- скриптами которые были добавлены разработчиками дле, чтобы это проверить попробуйте заменить

Вариант использовать старые js-скрипты от старой версии дле 10 файлы engine/classes/js/jquery.js и engine/classes/js/jqueryui.js заменить вместо старыми от версии 10.0 и проверить, чаще бывает в них проблема
  • № :69
  • 14 августа 2016 17:00
я вообще то из всех папок по папкам раскидывал и переименовывать в моё случае нет смысла!
  • № :68
  • 14 августа 2016 15:10
Цитата: korel
давай хоть один модуль для 10.3 доведём до ума а то не один не пашет как надо!

вообще-то они все нормально работают, смотрите сколько скачали, тогда у всех были проблемы с модулем.
Есть причина, она может быть связана с хостингом (пример если почитать комментарии ниже) и вторая с установкой модуля.
Например при заливке забыли поменять папку Default и теперь исполняющие файлы не в вашем шаблоне.
  • № :67
  • 14 августа 2016 11:55
давай хоть один модуль для 10.3 доведём до ума а то не один не пашет как надо!
  • № :66
  • 14 августа 2016 11:21
Цитата: dle9.com
в настройках к модулю в панели движка дле можно включить выключить хинт, проверьте включен хинт

Не нашел такую опцию в настройках дле в настройке данного модуля- включить выключить хинт, но у меня там всё включено, ещё, есть варианты, может сам у меня глянешь а я уж сам править буду? Или подскажи что и где искать
  • № :65
  • 14 августа 2016 10:39
Цитата: korel
Цитата: dle9.com
Цитата: korel
У меня не всплывает хинт, вообще тишина, дле 10.3 подскажите, что делать!

на счет этого установите шаблон от движка проверьте работу модуля, чтобы исключить проблемы с шаблоном

Установил шаблон от движка, то же самое хинт не всплывает!

в настройках к модулю в панели движка дле можно включить выключить хинт, проверьте включен хинт
  • № :64
  • 14 августа 2016 08:44
Цитата: dle9.com
Цитата: korel
У меня не всплывает хинт, вообще тишина, дле 10.3 подскажите, что делать!

на счет этого установите шаблон от движка проверьте работу модуля, чтобы исключить проблемы с шаблоном

Установил шаблон от движка, то же самое хинт не всплывает!
  • № :63
  • 14 августа 2016 07:36
Цитата: korel
У меня не всплывает хинт, вообще тишина, дле 10.3 подскажите, что делать!

на счет этого установите шаблон от движка проверьте работу модуля, чтобы исключить проблемы с шаблоном
  • № :62
  • 14 августа 2016 05:54
У меня не всплывает хинт, вообще тишина, дле 10.3 подскажите, что делать!
  • № :61
  • 2 марта 2016 23:09
Цитата: Chessman
windows 10 добавить бы

согласно списку

Windows 7 — Windows NT 6.1
Windows 8 — Windows NT 6.2
Windows 8.1 - Windows NT 6.3
Windows 10.0 (Windows Threshold) Windows NT 6.4
NT 6.4 - это ядро

получаем, запускаем поиск по слову Windows находим один единственный подходящий файл online.class.php

находим строчку кода

.*Windows NT 6.3.*#si" => "Windows 8.1 Blue"

добавляем определение Windows 10.0 сразу после этой строчки

.*Windows NT 6.4.*#si" => "Windows 10.0"


т.е. получаем (можно найти и сделать замену первого кода)

.*Windows NT 6.3.*#si" => "Windows 8.1 Blue".*Windows NT 6.4.*#si" => "Windows 10.0"


все просто
  • № :60
  • 2 марта 2016 21:43
windows 10 добавить бы
  • № :59
  • 4 июля 2015 15:23
Цитата: kinoskat
кривуший модуль

а поподробней, в чем проблема
  • № :58
  • 4 июля 2015 14:43
кривуший модуль