Глоссарий 2.0 модуль для DLE 10.4

Категория: Модули DLE » Модуль для DLE 11.2, 11.1, 11.0, 10.6, 10.5, 10.4, 10.3, 10.2, 10.1, 10.0, 9.8, 9.7, 9.6, 9.5, 9.4, 9.3, 9.2, 9.0
Глоссарий 2.0 модуль для DLE 10.4
Представляем бесплатный модуль для DLE 10.4 Glossary Глоссарий 2.0 - выводящий на отдельной странице слова-термины на вашем сайте под управлением движка DataLife Engine 10.4-10.2. Модуль DLE Glossary ищет в полной и краткой новостях, на статических страницах заданные администратором слова и выводит к ним hint описание, либо ссылается на отдельную страницу с описанием данного слова. www.dle9.com


Из раздела модули для dle Глоссарий 2.0
Версия движка: дле 10.4 / 10.2
Авторы: BDSoft, Roman Borkunov
Доработка: Roman Bork.

Важно:
Если вы обновляетесь с версии 1.5, необходимо выполнить все, что указано в install.html заново, кроме пункта про выполнение файла install.php

Скопируйте все файлы из папки upload в данном архиве на ваш сервер.
Запустите install.php
Открываем engine/engine.php, в нем ищем:
    switch ($do) { Ниже вставляем: case "glossary" : include( ENGINE_DIR."/modules/glossary/glossary.php" ); break; Ищем: elseif ($do == 'feedback') $nam_e = $lang['title_feed'];

Ниже вставляем:
elseif ($do == 'glossary') $nam_e = "Глоссарий";

Открываем .htaccess, в нем ищем:
    ReWriteEngine On Ниже вставляем: # Glossary 2.0 RewriteRule ^glossary(/?)+$ index.php?do=glossary [L] RewriteRule ^glossary/([^/]+)(/?)+$ index.php?do=glossary&word=$1 [L] RewriteRule ^glossary/page/([^/]+)(/?)+$ index.php?do=glossary&page=$1 [L]

Открываем engine/modules/show.full.php, в нем ищем:
    $tpl->set( '{title}', $row['title'] ); Ниже вставляем: // Glossary 2.0 $do = "full_story"; require_once ENGINE_DIR . '/modules/glossary/insert.php'; // Glossary 2.0

Открываем engine/modules/show.short.php, в нем ищем:
    $tpl->set( '{title}', $row['title'] ); Ниже вставляем: // Glossary 2.0 $do = "short_story"; require ENGINE_DIR . '/modules/glossary/insert.php'; // Glossary 2.0

Открываем engine/modules/show.custom.php, в нем ищем:
    $tpl->set( '{title}', $row['title'] ); Ниже вставляем: // Glossary 2.0 $do = "custom"; require ENGINE_DIR . '/modules/glossary/insert.php'; // Glossary 2.0

Открываем engine/modules/static.php, в нем ищем:
    $tpl->set( '{description}', $static_descr ); Выше вставляем: // Glossary 2.0 $do = "static"; require ENGINE_DIR . '/modules/glossary/insert.php'; // Glossary 2.0


Скачать DLE 10.4 модуль
  • 60
Рубрика: DLE модули » Бесплатные
Ранее » Модуль для DLE Conclusion attachments v3.1« Далее AllVotes
Добавление комментарияОставить комментарий
  • № :11
  • 6 июня 2015 14:10
Цитата: dle9


О ... ) Спасибо!
  • № :10
  • 6 июня 2015 13:59
Цитата: zzzzzz
Почему нет буквенного каталога, как на картинке в этой новости?

Вот если что сайт поддержка данного модуля
Внимание! У вас нет прав для просмотра скрытого текста.
, думаю эти вопросы лучше адресовать автору!?
  • № :9
  • 6 июня 2015 13:47
Почему нет буквенного каталога, как на картинке в этой новости?
  • № :8
  • 6 июня 2015 13:42
Почему текст не разбивается на абзацы?
Когда по ссылке смотришь термин - весь текст в куче :(((
(а в редакторе все с абзацами и т.п.)
  • № :7
  • 1 апреля 2015 18:56
Цитата: snamp
На 10,0 пойдет?

да вроде нет Версия движка: дле 10.4 / 10.2 только если помучаете
  • № :6
  • 1 апреля 2015 15:52
На 10,0 пойдет?
  • № :5
  • 9 марта 2015 13:55
Благодарю
  • № :4
  • 9 марта 2015 13:27
Цитата: AlexShadowman
Верся 5.3 Какая нужна?

5.5 похоже ,

но прежде сделайте следующее , в админке дле в управление БД сделайте ремонт БД и оптимизацию , далее очистите КЕШ и проверьте не поможет останется только 5.5 проверять можно на ДЕНВЕРЕ
у автора не написано какая версия более подходящая для модуля
  • № :3
  • 9 марта 2015 13:14
Верся 5.3 Какая нужна?
  • № :2
  • 9 марта 2015 13:01
Цитата: AlexShadowman
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-5 , 5' at line 1
SQL query:

Поинтересуйтесь у тех поддержки сервиса какая версия PHP соответствует ли она данному модулю
  • № :1
  • 9 марта 2015 12:53
У меня такая проблема после установки, подскажите как исправить:

Движок: DLE 10.3

Выдает такую ошибку:

MySQL error in file: /engine/modules/glossary/glossary.php at line 72
Error Number: 1064
The Error returned was:
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-5 , 5' at line 1
SQL query:

SELECT * FROM dle_glossary LIMIT -5 , 5